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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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Classic Icepak File Conversion

This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This guide is intended as supplementary material to Icepak for beginners and advanced users. It
includes instructions to convert a Classic Icepak project (.tzr file) into an Electronics Desktop Ice-
pak design. This guide also reviews how elements of a Classic Icepak project are represented in
Electronics Desktop.

Sample Project - Classic Icepak Project

Figure 1-1: Converted Classic Icepak Project

Classic Icepak File Conversion
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2 - Opening the Classic Icepak Project
This chapter contains the following topics:

l Open the Classic Icepak Project
l Classic Icepak File Conversion Limitations

Open the Classic Icepak Project
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the applic-
ation is installed.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

Classic Icepak File Conversion
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3. ClickOK.

Open the Project

1. On the Desktop ribbon tab, click Open Examples. Then:
a. In theOpen dialog box that appears, click the parent folder icon ( ) once to move

up one level above the Examples folder.
b. Double-click the Help folder and then the Icepak folder.
c. From the Files of type drop-down list, select Icepak Classic Project (*.tzr).
d. Select the file ClassicIcepakProject.tzr and clickOpen.

2. The model is displayed in the 3D Modeler window.

Note: You can hide the grid by selecting View >Grid Settings and then selecting Hide in
theGrid Spacing dialog box. Also, from the View > Coordinate Systemsmenu, you can
hide the large coordinate triad and display a smaller coordinate triad in the bottom of the
3D Modeler window.

Open the Classic Icepak Project 2-2
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Classic Icepak File Conversion

Figure 2-1: Model in the 3D Modeler window

3. From the Filemenu, select Save As, and save the project in the desired working dir-
ectory.

Classic Icepak File Conversion Limitations
Reference the Icepak online help for detailed information on what is currently unsupported when
opening an Icepak Classic project in the Electronics Desktop.

Open the Classic Icepak Project 2-3
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3 - Reviewing the Icepak Design
This chapter contains the following topics:

l Geometry and Boundary Conditions
l Global Mesh Settings
l Mesh Regions
l Monitors
l Design Settings and Solution Setup
l Design Variables and Parametric Setup
l Postprocessing
l Fields Summary Report

Geometry and Boundary Conditions
Classic Icepak objects are converted to geometry and, depending on the object, assigned a
boundary condition or native component, which contains its thermal properties. Geometry is dis-
played in the 3D Modeler window and listed in the history tree. Boundary conditions and Icepak
native 3D components are displayed in the Project Manager.

1. View the image below, which displays a Classic Icepak fan object in the Project tree, Fans
panel, and modeler window.

Classic Icepak File Conversion
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Classic Icepak File Conversion

Figure 3-1: Classic Icepak Fan Object

2. In the Electronics Desktop, expand the model components in the history tree to view the
geometry. Geometry selections in the history tree and highlighted as selections in the 3D
Modeler window.

Figure 3-2: Model Geometry in the History Tree

3. In the Project Manager, expand 3D Components to view the fan component and
Thermal to view boundary conditions. Right-click on the fan component and select Edit
Definition to view its thermal properties. Double-click on boundary conditions to view
thermal properties.

Reviewing the Icepak Design 3-2
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Classic Icepak File Conversion

Figure 3-3: Boundary Conditions and Fan Component Dialog Box

Global Mesh Settings
Global mesh settings from theMesh control panel in Classic Icepak are displayed in theMesh
Region dialog in the Electronics Desktop. After generating mesh in the Electronics Desktop, dis-
play controls and quality metrics are displayed in theMesh visualization dialog.

Reviewing the Icepak Design 3-3
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Classic Icepak File Conversion

1. View the image below, which displays the global Mesh control panel in Classic Icepak.

Figure 3-4: Classic Icepak Fan Object

2. On the Simulation ribbon, clickGlobal Mesh Settings. Click the Advanced tab to view
the global mesh settings.

Reviewing the Icepak Design 3-4
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Classic Icepak File Conversion

Figure 3-5: Model Geometry in the History Tree

3. On the Simulation ribbon, clickMesh Viewer to view the mesh visualization options and
mesh quality metrics.

Figure 3-6: Mesh Visualization Display Tab
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Classic Icepak File Conversion

Figure 3-7: Mesh Visualization Quality Tab

Mesh Regions
Assemblies in Classic Icepak are converted as mesh regions in the Electronics Desktop. The
mesh region has geometry, which is displayed in the history tree. The mesh settings are dis-
played in theMesh Region dialog box, which can be accessed by double-clicking on the mesh
region in the Project Manager.

Reviewing the Icepak Design 3-6
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Classic Icepak File Conversion

1. View the image below, which displays the meshing options for a Classic Icepak assembly.

Figure 3-8: Classic Icepak Assembly Meshing Options

2. In the Project Manager, expandMesh and double-click the mesh region. In the SubRe-
gion dilaog box, define padding settings to expand or shrink the mesh region. Then, in the
Mesh Region dialog box, click the Advanced tab to view the region's mesh settings.

Reviewing the Icepak Design 3-7
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Classic Icepak File Conversion

Figure 3-9: Mesh Region Options

Monitors
Point monitors in Classic Icepak are converted to the Electronics Desktop and are displayed in
the 3D modeler window. Point monitors are listed underMonitor in the Project Manager, and
geometry is displayed in the history tree. The monitor point settings are displayed in theMonitor
Setup dialog.

Reviewing the Icepak Design 3-8
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Classic Icepak File Conversion

1. View the image below, which displays a monitor point in Classic Icepak.

Figure 3-10: Classic Icepak Monitor Options

2. In the Project Manager, expandMonitor and double-click a point monitor. In theMonitor
Setup dialog box, review the point monitor's settings.

Reviewing the Icepak Design 3-9
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Classic Icepak File Conversion

Figure 3-11: Monitor Setup Options

Design Settings and Solution Setup
Classic Icepak Basic settings, Advanced settings, and Basic parameters are displayed in
the Design Settings dialog and Icepak Solve Setup Dialog in the Electronics Desktop.

1. View the images below, which display Icepak Basic settings, Advanced Settings, and
Basic parameters.

Reviewing the Icepak Design 3-10
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Classic Icepak File Conversion

Figure 3-12: Classic Icepak Basic Settings
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Classic Icepak File Conversion

Figure 3-13: Classic Icepak Advanced Settings

Figure 3-14: Classic Icepak Basic Parameters

2. From the Icepakmenu, click Design Settings to view the Ambient Conditions and
Gravity settings.

Reviewing the Icepak Design 3-12
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Classic Icepak File Conversion

Figure 3-15: Design Settings - Ambient Conditions Tab

Figure 3-16: Design Settings - Gravity Tab

Figure 3-17: Design Settings - Validations Tab

Reviewing the Icepak Design 3-13
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Classic Icepak File Conversion

Figure 3-18: Design Settings - Export Settings Tab

Figure 3-19: Design Settings - Mesh Tab

3. In the Project Manager, expand Analysis and double-click the solution setup to view the
General settings, Convergence settings, Solver Settings, and Radiation settings.

Reviewing the Icepak Design 3-14
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Classic Icepak File Conversion

Figure 3-20: Icepak Solve Setup Dialog - General Tab

Figure 3-21: Icepak Solve Setup Dialog - Convergence Tab
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Classic Icepak File Conversion

Figure 3-22: Icepak Solve Setup Dialog - Solver Settings Tab

Figure 3-23: Icepak Solve Setup Dialog - Radiation Tab
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Classic Icepak File Conversion

Design Variables and Parametric Setup
Design variables from the Classic Icepak project are displayed in the Properties dialog in the
Electronics Desktop. Classic Icepak parametric trials are displayed in the Setup Sweep Ana-
lysis dialog.

1. View the images below, which display Icepak design variables and parametric trials.

Figure 3-24: Classic Icepak Design Variables

Reviewing the Icepak Design 3-17
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Figure 3-25: Classic Icepak Parametric Trials

2. From the Projectmenu, click Project Variables to view the project variables in the Prop-
erties dialog box.

Figure 3-26: Icepak Parametric Trials

3. In the Project Manager, expand Thermal and double-click the a block boundary con-
dition. Note the variable in the Total Power definition.
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Figure 3-27: Icepak Variable in Block Boundary Condition

4. In the Project Manager, expandOptimetrics and double-click the parametric setup to
open the Setup Sweep Analysis dialog box. Review the trials defined on the Sweep
Definitions tab.

Figure 3-28: Icepak Sweep Setup
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Postprocessing
Post-processing objects from the Classic Icepak project are displayed in the 3D Modeler win-
dow and are listed under Field Overlays in the Project Manager.

1. View the image below, which displays a plane cut of velocity vectors in Classic Icepak.

Figure 3-29: Classic Icepak Velocity Vectors Plane Cut

2. In the Project Manager, expand Field Overlays to display the defined overlays. Expand
one, right-click on the overlay, and selectModify Field Plot to view the definition in the
dialog box.

Reviewing the Icepak Design 3-20
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Classic Icepak File Conversion

Figure 3-30: Icepak Field Plot - Velocity Vectors Plane Cut

Fields Summary Report
A Classic Icepak summary report is converted to a fields summary in the Electronics Desktop.

1. View the image below, which displays a summary report in Classic Icepak.
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Figure 3-31: Classic Icepak Summary Report

2. On the Results ribbon, click Fields Summary to display the fields summary report.

Figure 3-32: Icepak Fields Summary Report

Reviewing the Icepak Design 3-22

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.


	Table of Contents
	1 - Introduction
	2 - Opening the Classic Icepak Project
	Open the Classic Icepak Project
	Set 3D UI Options
	Open the Project

	Classic Icepak File Conversion Limitations

	3 - Reviewing the Icepak Design
	Geometry and Boundary Conditions
	Global Mesh Settings
	Mesh Regions
	Monitors
	Design Settings and Solution Setup
	Design Variables and Parametric Setup
	Postprocessing
	Fields Summary Report


